Group Details Private

Shop Creator [Trusted]

Those shop creators whose new products can be published without administrator's approval.

  • RE: Sketchucation Tools 4.4.0

    @Rich-O-Brien
    With an HtmlDialog SketchUp caches its 'chromium' stuff somewhere like here:
    C:\Users\USERNAME\AppData\Roaming\SketchUp\SketchUp 2024\WebCache-112.0.5615.165
    I don't know what's in it or how to clear it !

    posted in Extensions & Applications Discussions
  • RE: [Plugin] ClothWorks v1.7.7 - 2 May 2022

    @dbrazina

    The error relates to

    File.exists?()
    

    this method was deprecated long ago and replaced with

    File.exist?()
    

    which is grammatically incorrect in English, but hey Ruby is international !
    The older version had worked for many years 'in tandem', but it's now been removed from the newest Ruby version which ships with v2024.
    So this now breaks older scripts that still include it...

    It's relatively easy to fix - I found 2 instances that needed fixing in the various SketchUcation tools scripts when I was preparing them for this current version !

    Another issue that the ClothWorks developer faces is that his code relies on some functions within some .so/.bundle files for different OSs, so he will need to compile new versions of these for compatibility with v2024's Ruby version...

    posted in Plugins
  • RE: Sketchucation Tools 4.4.0

    @kenarneson
    Thanks for checking.
    The 'rbconfig' was a mistype and shouldn't be there, I've edited that list !

    posted in Extensions & Applications Discussions
  • RE: Sketchucation Tools 4.4.0

    @kenarneson
    This is weird.
    Yours is the only report like this.

    Your SketchUp is refusing to load the 'ZIP' methods needed to extract and then install the RBZ in AutoInstall mode through the dialog.

    The code you tried in the Ruby Console should return => "constant"
    So something is adrift.

    Please can you look in the subfolder:
    C:/Users/kenar/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/SketchUcation/Data/Rubyzip
    And check that these exist...
    zip.rb
    zip
    [folder]
    and that folder's contents...
    'zip/dos_time'
    'zip/ioextras'
    'rbconfig'
    'zip/entry'
    'zip/extra_field'
    'zip/entry_set'
    'zip/central_directory'
    'zip/file'
    'zip/input_stream'
    'zip/output_stream'
    'zip/decompressor'
    'zip/compressor'
    'zip/null_decompressor'
    'zip/null_compressor'
    'zip/null_input_stream'
    'zip/pass_thru_compressor'
    'zip/pass_thru_decompressor'
    'zip/inflater'
    'zip/deflater'
    'zip/streamable_stream'
    'zip/streamable_directory'
    'zip/constants'
    'zip/errors'

    Also check that the following were available to be loaded by SketchUp from the Tools subfolders
    C:\Program Files\SketchUp\SketchUp 2024\Tools\gems\3.2.0\gems\rbs-2.8.2\stdlib\zlib\0\zlib.rbs
    and more importantly
    C:\Program Files\SketchUp\SketchUp 2024\Tools\RubyStdLib\platform_specific\zlib.so

    If they are... check the C:\Program Files\SketchUp\SketchUp 2024\Tools folder and contents have suitable permissions... properties>security>edit, and reset to 'Full control' for ALL those entries listed

    Also right-click on the subfolder
    C:/Users/kenar/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/SketchUcation
    and look at its properties>security>edit, and reset to 'Full control' for ALL those entries listed.
    Restart SketchUp and see if that helped

    posted in Extensions & Applications Discussions
  • RE: [Plugin] 2D Tools

    @alskaro
    What is your actual OS ?
    Is there any output in the Ruby Console ?
    There are some issues with some of the tools in newer MAC OSs.
    A fix has not yet been published.

    posted in Plugins
  • RE: Sketchucation Tools 4.4.0

    @kenarneson
    This is the first report like this.

    The initial error seems to be unrelated to the SketchUcation toolset - it refers to a load error in ../RubyStdLib/.. loading zlib.so

    This then seems to throw the SketchUcation/SCF_loader.rbe off in line 67 where it tries to load the various support rbe files...
    The later on when it fails to load some 'zip' methods etc involving zlib...
    So it looks to me like the issue is 'yours' - with a failure to get beyond first base...

    First off - how did you install the SketchUcation toolset RBZ ?

    Next, have you installed SketchUp properly ?
    If you have not it sometimes doesn't copy files to the right places with suitable permissions etc...
    And thereby causes all kinds of weirdness...

    You can fix this without re-installing, or affecting any customization you might have set up already...

    Close SketchUp.
    Find the appropriate SketchUp installer's exe file [usually in your Downloads folder, or if you have deleted it download a new copy].
    Select the installer's exe file's icon, right-click > context-menu > "Run as administrator"
    When prompted choose 'Repair'
    When it completes restart your PC and see if it's better.

    Using a complex app's exe by double-clicking it to 'Run' it is not the same thing - even if you have admin-powers.
    Doing a Repair does no harm anyway !

    FYI: the RBZtool runs this after temporarily loading a ZIP lib.

    require('zlib') unless defined?(Zlib)
    require('zip')  unless defined?(Zip)
    

    It requires some ZIP code unless it's been already installed - e.g. by an earlier loading RB from another author...
    To check if that's so try this in the Ruby Console

    defined?(Zlib)
    

    then

    defined?(Zip)
    

    You should get something like 'constant'.

    Please report back...

    posted in Extensions & Applications Discussions
  • RE: [Plugin][$] JointPushPull Interactive - v4.8a - 30 Mar 24

    @Dandelliones
    OK I'll try to get someone else to resolve this...
    @Rich-O-Brien

    posted in Plugins
  • RE: [Plugin][$] JointPushPull Interactive - v4.8a - 30 Mar 24

    @Dandelliones
    Have you installed the latest versions of the SketchUcation toolset [v4.4.0], LibFredo and the Fredo extension itself ?
    These have been updated for the latest SketchUp version etc...
    Have you restarted SketchUp afterwards ?
    Have you then tried managing your licenses yourself with the menu item

    Extensions/SketchUcation/SCFLicense: My Licenses at SketchUcation...
    
    posted in Plugins
  • RE: Purge is crashing SU2024

    @grizzler

    You should go to the PluginStore and update to the SketchUcation toolset v4.4.0 which has been specially reworked for v2024 compatibility. If deals with the SCF licensing for many extensions.
    If you use any of Fredo's extensions, he has also updated them all for v2024 use and don't forget his latest LibFredo too...
    After installing these restart SketchUp to sync everything...

    posted in SketchUp Discussions
  • RE: Purge is crashing SU2024

    I don't see this.
    I assume you are using Windows ?
    When you installed SketchUp did you do it the proper way ?
    You can 'Repair' the installation without losing any of your customization.
    Do this...
    Close SketchUp.
    Find the SketchUp installer's exe file - usually in your Downloads folder [download another copy if you haven't kept it]
    Select the installer's exe file's icon and right-click > context-menu > 'Run as administrator'
    When prompted choose 'Repair'.
    When it completes restart your computer and try SketchUp again...
    Any improvement ?
    Also look at your Preferences and try different Graphics Card / Engine settings...

    posted in SketchUp Discussions