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3skeng - Starting Guide 

 

To use 3skeng tools and libraries for SketchUp on your computer, you may follow 

the whole guide or just jump to topics of interest by clicking on a title below. 
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1) Download 3skeng 

 

Go to www.3skeng.com and browse to the download section. 

 

Download installation file of your choice: 

- Ruby file for extension installation in SketchUp (for MAC OS and Windows OS). 

- Archive-file with installer for Windows OS (installation requires admin rights for 3skeng user). 
 

  

http://www.3skeng.com/
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2) Installation of 3skeng 

 

Installation of 3skeng by installer for Windows OS (if available): 

- IMPORTANT: 

  Login on your computer as the user who will use SketchUp with 3skeng (admin rights required)! 

  3skeng will not be available for the desired user if you temporarily login with another account with  

  admin rights or execute the file as admin. Only the admin will be able to use 3skeng. 

  If you have no admin rights, please use the “Installation of 3skeng by Ruby file”. 

- Unpack the archive and execute the 3skeng setup file. 

- Check the boxes for the 3skeng tool(s) you want to install for each of the SketchUp version(s) you  

  have installed on your computer. 

 

Installation of 3skeng by Ruby file for SketchUp 2016/2015/2014 

- IMPORTANT: 

  Login on your computer as the user who will use SketchUp with 3skeng! 

- Select Window > Preferences (Windows OS) or SketchUp > Preferences (Mac OS).  

   The Preferences dialog box is displayed. 

- Click on Extensions. The Extensions panel is displayed. 

- Click on the Install Extension button. The Open dialog box is displayed. 

- Locate the Ruby zip file to install (3skeng_xxxx.rbz). 

- Click on the Open button. 

- After the installer completes, quit and restart SketchUp. 

 

   
 

- Open the “Preferences” dialogue box again. 

- Again, click on “Extensions”. “3skeng Engineering 2016” can now be found in the list of extensions. 

- Select the extension to activate it. 
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Installation of 3skeng by Ruby file for SketchUp 2017 

- IMPORTANT: 

  Login on your computer as the user who will use SketchUp with 3skeng! 

- Select Window > Extension Manager 

   The Extension Manager dialog box is displayed. 

- Click on Install Extensions (see screenshot). The Open dialog box is displayed. 

- Locate the Ruby zip file to install (3skeng_xxxx.rbz). 

- Click on the Open button. 

- After the installer completes, quit and restart SketchUp. 

 

 

 

- Open the “Extension Manager” dialogue box again. 

- Make sure that “3skeng Engineering 2017” can now be found in the list of extensions 

  and the button is set to “Enabled”. 
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3) What if the 3skeng toolbar is not available in SketchUp 2016? 

 

a) Open SketchUp 2016. If the 3skeng activation window opens, proceed with 4) 

 

b) Open SketchUp 2016. If you see the 3skeng toolbar, click the 3skeng symbol and proceed with 4)  

 

c) If the 3skeng activation window doesn’t open and the 3skeng toolbar is not displayed, please 

check and maybe adjust your extension policy settings. 

To do so, open the “System Preferences” by selecting it in “Window -> Preferences” 

Click on “Extensions Policy” and check your settings. 

 

 
 

“Identified Extensions Only” 

This setting will not allow you to use the 3skeng extension at all. 

“Approve Unidentified Extensions” 

This setting will prompt you to check all installed extensions after each start of SketchUp in order to 

load the checked extensions. 

“Unrestricted” 

This setting will load all your installed extensions after each start of SketchUp automatically. 

 

Restart SketchUp 2016 in case you decide to change the “Extension policy” settings. 

 

d) If the toolbar is (still) not available after restart, open the 3skeng toolbar by selecting it in: 

MAC OS: “View -> Tool Palettes” (dropdown menu).  

Windows OS: “View -> Toolbars…” 
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4) Request activation key for 3skeng 

 

a) Open SketchUp and click on the 3skeng symbol in the 3skeng toolbar. 

 

b) The 3skeng activation window opens. 

 

 
 

c) Please enter your email-address: 

Current/Registered users: 

Enter the same e-mail that you used previously for 3skeng activations & purchases (already user). 

In case you forgot: The address can be found by opening a previous version of SketchUp where an 

earlier version of 3skeng was installed. Click on the 3skeng symbol in the 3skeng tool palette. The 

email address that was used to previously register 3skeng will be displayed. 

New users: 

Enter an e-mail you need access to and want to use as the future user (new user). 

 

d) Select if you are already a 3skeng user or a new user.  

e) Fill out the short survey on the right with your main usage for 3skeng, your country (required) 

and your industry. 

f) Click on “get activation code”. 

g) Do not close the activation window.  
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5) Activation of 3skeng 

 

An activation key (one-time use) will be sent to the specified email address.  

 

 
 

If you do not get an email, make sure the email address is correct and check your junk email folder! 

   
 

a) Enter the activation code from the email in the appropriate field. 

b) Click on “activate…”. 

c) Allow 3skeng to download required files. Please have a little patience for this process... 

d) Restart SketchUp when prompted. 

e) Allow 3skeng to generate your local database after the restart of SketchUp.  
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6) Add tools (Demo or purchase) 

 

Go to "manage tools" in the 3skeng client window tab “my 3skeng” (see screenshot) to add demo 

versions and/or purchase tools. 

 

 

 

Learn more about the 3skeng license terms for tools and libraries here: 

http://www.3skeng.com/3s-products/License3skengEn.htm  
 

  

http://www.3skeng.com/3s-products/License3skengEn.htm
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7) Add detail libraries (Purchase) 

 

To access the available libraries open the 3skeng client tab “my 3skeng” click on “manage libraries”, 

browse to libraries of your interest and click on “here” to learn more about the libraries content in 

pdf-files. 

 

 

 

To add a library, open the 3skeng client tab “my 3skeng” click on “manage libraries” and click on 

“Buy now” to purchase a detail library. 
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8) Missing library parts / equipment / facilities / components 

 

The available libraries includes selected standard parts for piping, tubing and ductwork. 

There are many manufacturers for many different applications (e.g. pumps, fans, air handling units, 

valves, dampers, etc.) available on the market. So we are well aware that we cannot fulfill our 

users’ expectations concerning library content (e.g. missing valve types and sizes) and nature of 

available libraries (e.g. no air handling unit library available). 

 

So we decided to provide a solution / workflow to make your own parts, equipment, facilities and 

components (e.g. drawn by yourself, 3D warehouse, etc.) compatible to 3skeng functions. 

We recommend that you set up your own customized SketchUp library file(s) that includes all the 

“missing” elements you need in your daily workflow. 

 

The parts, equipment, facilities and components you create won’t become a part of a 3skeng library 

directly but 3skeng recognizes integrated reference points and will select the appropriate pipe or 

connectors (e.g. Flange, VCR-f, etc.) for line attachment and can also work with the functions 

edit/rotate and connect (e.g. facility / utility connections of an air handling unit). 

 

You just have to consider that the right-click function “select line/all connected” doesn’t select these 

3skeng-compatible parts as part of the line (if you don’t right-click after selecting on all them). This 

is because this “3skeng compatible component” function can also be used for machines with 

connections of different utilities and we don’t want to select all lines with different pipe materials and 

different utilities. 

 

The fastest way to make parts/components compatible to the 3skeng tools is simply to add 

appropriate 3skeng components (e.g. flange) or pieces of pipe in those components.  

Learn more in the tutorial “3skeng compatible groups & components” by clicking on the grey arrow 

in the tutor tab of the client window. 
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9) How to learn to use 3skeng  

 

3skeng was designed to follow the easy and intuitive use of SketchUp and at the same time provide 

powerful and useful functionality. 

 

To bring you up to speed with what you can do with 3skeng tools, we provide learning files in 

SketchUp format. 

 

The files guide you through the available functions of the tools scene by scene.  

You are asked to use specific values and angles to allow you to compare your result with the 

specified result at the end. 

 

Pdf-files that contain the scene descriptions in case you have trouble to read the texts on your 

screen are also available for download. 

 

We recommend to use the given file order and just skip tools (files) you are not interested in.  

The file (6) Edit & Rotate / Connect covers the functions for all other tools. 

 

Click the following links to download the individual files or an archive that contains them all: 

 

Learn to use (1) 3skeng Pipe conceptual (skp) 

Learn to use (1) 3skeng Pipe conceptual (pdf) 

 

Learn to use (2) 3skeng Pipe detail (skp) 

Learn to use (2) 3skeng Pipe detail (pdf) 

 

Learn to use (3) 3skeng Channel (skp) 

Learn to use (3) 3skeng Channel (pdf) 

 

Learn to use (4) 3skeng Steelwork (skp) 

Learn to use (4) 3skeng Steelwork (pdf) 

 

Learn to use (5) 3skeng Mount (skp) 

Learn to use (5) 3skeng Mount (pdf) 

 

Learn to use (6) 3skeng Edit & Rotate / Connect (skp) 

Learn to use (6) 3skeng Edit & Rotate / Connect (pdf) 

 

 

Learn to use 3skeng (1)-(6).zip (skp & pdf)  

http://www.3skeng.com/download/Learn-to-use-(1)-3skeng-Pipe-conceptual_ver.1.0.skp
http://www.3skeng.com/download/Learn-to-use-(1)-3skeng-Pipe-conceptual_ver.1.0.pdf
http://www.3skeng.com/download/Learn-to-use-(2)-3skeng-Pipe-detail_ver.1.0.skp
http://www.3skeng.com/download/Learn-to-use-(2)-3skeng-Pipe-detail_ver.1.0.pdf
http://www.3skeng.com/download/Learn-to-use-(3)-3skeng-Channel_ver.1.0.skp
http://www.3skeng.com/download/Learn-to-use-(3)-3skeng-Channel_ver.1.0.pdf
http://www.3skeng.com/download/Learn-to-use-(4)-3skeng-Steelwork_ver.1.0.skp
http://www.3skeng.com/download/Learn-to-use-(4)-3skeng-Steelwork_ver.1.0.pdf
http://www.3skeng.com/download/Learn-to-use-(5)-3skeng-Mount_ver.1.0.skp
http://www.3skeng.com/download/Learn-to-use-(5)-3skeng-Mount_ver.1.0.pdf
http://www.3skeng.com/download/Learn-to-use-(6)-3skeng-Edit-Connect_ver.1.0.skp
http://www.3skeng.com/download/Learn-to-use-(6)-3skeng-Edit-Connect_ver.1.0.pdf
http://www.3skeng.com/download/Learn-to-use-(1)-(6)-3skeng_ver.1.0.zip
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10) How to buy  

 

There are multiple ways to get your 3skeng license: 

 

Use the integrated shop of the 3skeng software 

You can buy in the integrated shop after installation and activation (please see picture below). We 

accept the payments methods PayPal, Credit Card (AMEX, JCB, MasterCard and VISA) and 

prepayment by bank transfer. 

Your purchased license is directly added to your account after successful payment and you receive 

an invoice of the purchase (You will not receive a transaction key). The license can be used after 

synchronization of 3skeng and restart of SketchUp. 

Good-to-know: We work with approved third party payment solution providers. During the 

purchase process, you are rerouted to the provider's encrypted SSL-page resulting in 3skeng/SHK 

having no contact with your payment data (e.g. credit card data) at any time whatsoever. 

What can I do in case of Credit Card transaction errors? 

The most common reason is that your Credit Card company declines international transactions by 

default. In such a case, please contact your credit card company or issuing bank to (temporarily) 

unlock Germany for your 3skeng purchase(s). 

 

 

 

Buy 3skeng by invoice 

In case you need multiple licenses for your seat and / or seats with multiple licenses for multiple 

users, we can prepare a custom quotation for you and send an invoice after you decide to buy 

(Payable by PayPal, Credit Card (AMEX, JCB, MasterCard and VISA) and bank transfer.) 

Your purchased license(s) will be delivered by license card with transaction key.  

Please contact sales@3skeng.com with your requirements or information request and we will take 

care of you. 

 

Buy 3skeng through resellers 

Browse to our website www.3skeng.com and go to “download -> buy 3skeng” where we provide a 

map with our resellers. Your purchased license(s) will be delivered by license card with transaction 

key.  

mailto:sales@3skeng.com?Subject=Quotation%20request%20for%203skeng%20licenses
http://www.3skeng.com/
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11) How to use a license card with transaction key 

 

Purchases through 3skeng by invoice and resellers are handed over by license card with a personal 

transaction key (for one time use only). 

 

a) Go to "manage account" in the 3skeng client window tab “my 3skeng”. 

 

b) Type in your transaction key from the provided license card. 

 

c) Click on button “Activate transaction key and synchronize the database”. 

 

d) Your purchased 3skeng license(s) are added to your account (registered e-mail address) in the 

process. 

 

e) The transaction key is for one time use only and turns invalid after its activation in step d). 
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12) How to deactivate and / or uninstall 3skeng 

 

Deactivate 3skeng  

To deactivate 3skeng, untag it in: 

MAC OS: “View -> Tool Palettes” (dropdown menu).  

Windows OS: “View -> Toolbars…” 

 

        

 

 

 

 

 

 

 

 

 

 

 

 

 

Uninstall 3skeng which was installed with Windows PC and / or MAC installer 

Please use the standard procedure to uninstall apps / programs for your operating system. 

 

Uninstall 3skeng which was installed with the Universal Installer (by *.rbz-file) 

Please deactivate 3skeng (see above), close SketchUp and manually delete the following: 

 

Delete “3skeng 2017” database folder: 

C:\Users\%username%\AppData\Roaming\3skeng_V2017\Sketchup 2017 

  

Delete “3skeng 2016” database folder: 

C:\Users\%username%\AppData\Roaming\3skeng_V2016\Sketchup 2016 

C:\Users\%username%\AppData\Roaming\3skeng_V2016\Sketchup 2015 

C:\Users\%username%\AppData\Roaming\3skeng_V2016\Sketchup 2014 

 

Delete “3skeng 2014” database folder: 

C:\Users\%username%\AppData\Roaming\3skeng_V2014\Sketchup 2015 

C:\Users\%username%\AppData\Roaming\3skeng_V2014\Sketchup 2014 

 

Delete 3skeng Plugin program folder: 

C:\Users\%username%\AppData\Roaming\SketchUp\SketchUp 2017\SketchUp\Plugins 

Delete folder “\shk_3skeng\” and file “shk_3skeng_extension.rb” 

C:\Users\%username%\AppData\Roaming\SketchUp\SketchUp 2016\SketchUp\Plugins 

Delete folder “\shk_3skeng\” and file “shk_3skeng_extension.rb” 

C:\Users\%username%\AppData\Roaming\SketchUp\SketchUp 2015\SketchUp\Plugins 

Delete folder “\shk_3skeng\” and file “shk_3skeng_extension.rb” 

C:\Users\%username%\AppData\Roaming\SketchUp\SketchUp 2014\SketchUp\Plugins 

Delete folder “\shk_3skeng\” and file “shk_3skeng_extension.rb” 


